Zum Inhalt springen
Das deutsche VCDS Forum
Das deutsche VCDS Forum

Software Bug VCDS 22.3.1 ??


Empfohlene Beiträge

#1 - Geschrieben (bearbeitet)

Hallo,

 

ich habe kürzlich bei einem Seat Leon Cupra im Stg 17 den Anpassungskanal IDE12467 (Tuben Darstellung) einige Male geändert.

Dabei wurde automatisch auch die Skala des Tachometers (Tachometer Endwert) von 300 auf 260 umgestellt.

Soweit so gut. Kennt man ja schon vom Golf 7, Passat B8 usw.

Als ich anschließend die Tuben Darstellung wieder auf Variante 0 geändert habe, blieb der Tachometer Endwert immer noch auf 260. Das ist bei einem Golf 7 oder Passat B8 nämlich nicht der Fall. Hier wird der Tachometer Endwert mit umgestellt.

Das Problem dabei, die Änderung des Tachometer Endwertes beim Seat Leon Cupra 5F läuft über einen anderen Anpassungskanal.

(Adresse 17,5F0 920 790 ,Anpassungskanal IDE13094-Tachometer Endwert)

 

Dies wusste ich allerdings zu dem Zeitpunkt noch nicht.

Dieser Umstand wäre halb so schlimm, wäre die Änderung des Anpassungskanals IDE13094 im AdpLog protokolliert. Das wird nämlich nicht gemacht!

Sprich, man ändert Kanal A und diese Änderung stellt autom. auch Kanal B um. Doch die Umstellung des Kanal B wird nicht gelogt!!

Da stehst du schon dämlich da, wenn du sowas bereits xxxx Mal gemacht hast und jetzt läuft alles anders und der Log der eigentlich alles Protokollieren sollte fehlt.

 

Ich denke das es sich hierbei um einen Bug im VCDS handeln kann.?

Falls dies so gewollt ist, dann soll mir bitte jemand verständlich erklären wieso die autom. Änderung eines zweiten oder gar dritten Anpassungskanals nicht mit gelogt wird!?

 

 

AdpLog.xlsx

Bearbeitet von toto99
Link zu diesem Kommentar

Ich denke der Kanal springt automatisch mit um, daher kann VCDS das nicht protokollieren. In einem zweiten Admap nach Änderung hättest du im Vergleich zum ersten ja gesehen was sich geändert hat, von daher halb so schlimm. Vorausgesetzt es wurde vor der ersten Änderung ein Admap erstellt.

Link zu diesem Kommentar

Das der zweite Kanal autom. Umspringt ist nicht das Problem, das Problem ist, er wird nicht wiederhergestellt wenn man den Ersten wieder zurücksetzt. So wie es zb. beim Golf 7, Passat B8, Skoda Octavia usw. der Fall ist.

Auch das wäre noch halb so schlimm, gäbe es von der Umstellung des zweiten Kanals ein Protokoll.

 

Ich bin wirklich jedem dankbar für eine sinnvolle Antwort, doch es ist nicht möglich von jedem Stg ein Abbild zu machen. Theoretisch natürlich, doch das musst du erstmal einem Kunden in der Praxis erklären, er muss das Fahrzeug für mehrere Stunden da lassen um von jedem Stg. ein Abbild zu machen. Das ist in der Praxis so einfach nicht drin. Vor allem dann nicht, wenn die Leute 1h oder mehr Anfahrt auf sich nehmen.

Ich bin weder zu faul noch zu bequem für ein Stg. Abbild, es ist nur völlig praxisfern.

Die Sicherung des Fahrzeugscans und der Adaptions Log waren bis jetzt vollkommen ausreichend als "Backup". Was ich bis jetzt zum Glück extrem selten in Anspruch genommen habe!

Doch wenn autom. geänderte Kanäle weder autom. zurückgesetzt noch protokolliert werden, dann ist in der Sache ein Loch drin.

 

In diesem Fall ist man gezwungen auf alternative Tools zurück zu greifen die nur den Kanal ändern der auch ausgewählt ist.

Denn ich bin mir um ehrlich zu sein nicht mehr wirklich sicher, was mich bei der nächsten Anwendung mit VCDS erwartet.

8 Jahre lang habe ich damit wirklich sehr gerne gearbeitet

 

Link zu diesem Kommentar

Für das Erstellen der adpmaps kann man auch ein Tool von @hadez16 benutzen (siehe seine Signatur), damit geht das je nach Fahrzeug in 5-15 Minuten. Ladegerät ist dann allerdings Pflicht.

 

Ich vermute, dass der Kanal nicht von VCDS automatisch umgestellt wird, sondern vom Steuergerät selbst. Damit kriegt VCDS es halt nicht mit. Das der Kanal nicht automatisch zurückspringt, dürfte dann ebenfalls dem Steuergerät zuzurechnen sein. Vielleicht ist es auch ein Feature, welches in einer neuen Software des Steuergerätes enthalten ist, die es bislang noch nicht in die G7, Passat B8, usw. geschafft hat und die deshalb dort nicht das Verhalten zeigen.

 

Wenn ein anderes Diagnosetool in genau dem betroffenen Steuergerät wirklich nur diesen Kanal ändert und den anderen nicht, dann wäre es mal ein Meldung an Rosstech wert, da ich dann von einem Bug in VCDS ausgehen würde. Oder das andere Tool kennt dieses Verhalten und ändert den zweiten Kanal selbstständig zurück, falls es doch ein Feature des Steuergerätes ist.

Link zu diesem Kommentar
#5 - Geschrieben (bearbeitet)

Beitrag entfernt, da nicht ganz korrekt. 

Bearbeitet von bluetdi

Ich bin Optimist. Das heißt aber nicht, dass ich mehr gebacken kriege als andere. Ich laufe halt nur fröhlich pfeifend ins Verderben. :wink:

Erstellen eines Abbildes: VCDS --> Anwendungen --> Steuergeräte-Abbild --> Anpassung und CSV wählen --> Adresse u. ggf. Login eingeben --> Start

 

Link zu diesem Kommentar
Am 2.7.2022 um 22:46 schrieb Uzi:

Für das Erstellen der adpmaps kann man auch ein Tool von @hadez16 benutzen (siehe seine Signatur), damit geht das je nach Fahrzeug in 5-15 Minuten. Ladegerät ist dann allerdings Pflicht.

ADPMAPS bei UDS Steuergeräten kann VCDS auch ohne das Tool komfortabel erstellen. Das Tool richtet sich an nicht UDS Steuergeräte

 

 

 

Link zu diesem Kommentar

....mir ist gestern erst aufgefallen, dass die Funktion "Admaps von allen Steuergeräten erstellen" kaputt ist: Man wird aufgefordert eine STG-Adresse einzugeben, obwohl man "Alle Steuergeräte" angehakt hat.

Darüber hinaus scheint mein AdpMapRoboter mit Version 22.x nicht mehr zu funktionieren....mist.

Service-Rückstellung für UDS-Tachos mit VCDServiceReset
VCDS automatisieren mit dem VCDScripter

Auto-Scans komfortabel darstellen & Codierungen vergleichen mit CodingCompare

Adpmaps automatischen anfertigen lassen mit Adpmap Robotor

Wie erstellt man eine Adpmap: VCDS --> Anwendungen --> Steuergeräte-Abbild --> Anpassung und CSV wählen --> Adresse eingeben --> Start

Link zu diesem Kommentar
  • 1 Monat später...
#8 - Geschrieben (bearbeitet)

Habe auch noch einen Bug. Wenn ich ein Steuergeräteabbild von allen Geräten erstellen will, klicke ich in der Maske Anwendungen\Steuergeräteabbild auf Alle Steuergeräte (nur CAN-Datenbus).
Was dabei schon auffällt ist, dass der Radio Button bei Adresse (für den Abruf einzelner Steuergeräte-Abbilder über Eingabe der Adresse) verbleibt. Es sind dann beide Radio Buttons ausgewählt, was der gegenseitigen Auslösung widerspricht.
Beim Klick auf Start will die SW folglich eine Eingabe im Adressfeld haben.
Ein Steuergeräteabbild über alle Geräte ist nicht mehr möglich.
Betriebssystem ist Win11.

KeinSteuergeräteAbbildÜberAlleGeräteMöglich.png

Bearbeitet von louk
Link zu diesem Kommentar

@louk

Bitte hinterlege deine Lizenz-/Seriennummer im Forenprofil.

!! Technische Anfragen per PN oder Nutzerkartenanfrage können nicht beantwortet werden !!

 

Lesenswert:

 

Auto-Scan richtig einfügen:

grafik.png

Link zu diesem Kommentar

Verwendest du wirklich die neuste Version von VCDS?

https://vcdspro.de/downloads/

 

Ich weiß, dass es zu Anfängen der Version 22 mit dem Fenster einige Probleme gab.

!! Technische Anfragen per PN oder Nutzerkartenanfrage können nicht beantwortet werden !!

 

Lesenswert:

 

Auto-Scan richtig einfügen:

grafik.png

Link zu diesem Kommentar
vor 40 Minuten schrieb Christian:

Verwendest du wirklich die neuste Version von VCDS?

 

Ja, siehst Du ja in der Titelzeile der Fenster. Habe sicherheitshalber die Version von Deinem Link gezogen und installiert. Es hat sich aber nichts geändert.

Link zu diesem Kommentar
vor einer Stunde schrieb louk:

Ja, siehst Du ja in der Titelzeile der Fenster.

Nicht unbedingt. Es gibt auch "Hotfixes", bei denen dies ersten 3 Nummern in der Version nicht geändert wird.

 

Wenn es mit der aktuellen Version aber immer noch so ist, hast du wohl einen Bug gefunden. 😉

  • Like 1

!! Technische Anfragen per PN oder Nutzerkartenanfrage können nicht beantwortet werden !!

 

Lesenswert:

 

Auto-Scan richtig einfügen:

grafik.png

Link zu diesem Kommentar

Der Fehler ist auf jeden Fall bekannt und wurde hier schon einmal thematisiert:

 

Meinem Kenntnisstand nach sollte ggf. im laufe der nächsten Woche eine neue VCDS Version erscheinen, in der dieser Fehler behoben ist 😉

Link zu diesem Kommentar
vor 5 Stunden schrieb Christian:

..., hast du wohl einen Bug gefunden. 😉

Die Hotfixes in der Versionsnummer nicht mitzuzählen ist aber nicht so gut. Wir (Maschinenbau-SW Entwicklung) haben vierstellige Versionsnummern, um die Bugfixes auch mitzählen zu können.
Wundert mich, dass das noch keiner gemeldet hat. Ist das jetzt für die Entwickler als Bug festgehalten worden, damit die sich darum kümmern?
Wann ist mit einer Behebung zu rechnen, weil die Funktion wichtig ist, um den Stand zu sichern, bevor man Änderungen vornimmt?

Kann man auch wieder eine älteren Version installieren?

Link zu diesem Kommentar
vor 1 Stunde schrieb louk:

Wundert mich, dass das noch keiner gemeldet hat. Ist das jetzt für die Entwickler als Bug festgehalten worden, damit die sich darum kümmern?

Hier liest kein Entwickler mit.

 

Du kannst die Fehlermeldung beschleunigen, in dem du das Problem im Herstellerforum meldest. 

https://forums.ross-tech.com/index.php

 

vor 1 Stunde schrieb louk:

Wann ist mit einer Behebung zu rechnen, weil die Funktion wichtig ist,

Das kann nur der Hersteller beantworten. Sie Link oben.

 

 

Du kannst auch einfach in den Einstellungen Debug-Stufe 2 eintragen und danach einen Auto-Scan starten. Das führt auch zu einem vollständigen Abbild vom Fahrzeug.

 

 

 

@PCI-Support-Josef Ich bin mir nicht sicher, ob es 100% das gleiche Fehlerbild ist.  

!! Technische Anfragen per PN oder Nutzerkartenanfrage können nicht beantwortet werden !!

 

Lesenswert:

 

Auto-Scan richtig einfügen:

grafik.png

Link zu diesem Kommentar
vor 3 Stunden schrieb louk:

Die Hotfixes in der Versionsnummer nicht mitzuzählen ist aber nicht so gut. Wir (Maschinenbau-SW Entwicklung) haben vierstellige Versionsnummern, um die Bugfixes auch mitzählen zu können.

Warum das so ist, wird dir nur der Hersteller beantworten können. Das ist der Grund, wieso wir auf unserer Webseite immer das Build Datum der aktuellsten Version mit ausgeben:

image.png

 

vor 3 Stunden schrieb louk:

Wundert mich, dass das noch keiner gemeldet hat. Ist das jetzt für die Entwickler als Bug festgehalten worden, damit die sich darum kümmern?

🤨  Wie in Beitrag #14 bereits geschrieben, ist der Fehler schon bekannt und sollte bald behoben sein

 

vor 3 Stunden schrieb louk:

Kann man auch wieder eine älteren Version installieren?

Du kannst alternativ die englische Version verwenden -in der tritt dieser Fehler nicht auf.

Oder du machst es so, wie es Christian oben bereits erwähnt hat .. VCDS => Einstellungen => "Debug-Stufe" = 2 => Speichern => AutoScan erstellen

 

vor 1 Stunde schrieb Christian:

@PCI-Support-Josef Ich bin mir nicht sicher, ob es 100% das gleiche Fehlerbild ist.  

Ich denke schon, bzw. dachte ich, dass das hier vor einiger Zeit schon mal zur Sprache kam (vielleicht war es auch ein anderer Beitrag).

Jedenfalls ist dem Hersteller das aktuelle Problem -wie hier beschrieben- schon bekannt und es sollte bald eine gefixte Version dafür geben 😉

  • Like 1
Link zu diesem Kommentar
  • 1 Monat später...
Am 7.8.2022 um 11:49 schrieb PCI-Support-Josef:

Jedenfalls ist dem Hersteller das aktuelle Problem -wie hier beschrieben- schon bekannt und es sollte bald eine gefixte Version dafür geben 😉

Wusste garnicht, dass der Hersteller was mit dem deutschen Branch zu tun hat 😉

Es ist mittlerweile Mitte September und der Bug im Abbild-Dialog ist ein dicker Pain-in-the-A....

Service-Rückstellung für UDS-Tachos mit VCDServiceReset
VCDS automatisieren mit dem VCDScripter

Auto-Scans komfortabel darstellen & Codierungen vergleichen mit CodingCompare

Adpmaps automatischen anfertigen lassen mit Adpmap Robotor

Wie erstellt man eine Adpmap: VCDS --> Anwendungen --> Steuergeräte-Abbild --> Anpassung und CSV wählen --> Adresse eingeben --> Start

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
×
×
  • Neu erstellen...

Wichtige Information

Wir benutzen Cookies, um Ihnen den bestmöglichen Service bieten zu können. Durch die weitere Nutzung dieser Webseite stimmen Sie der Verwendung von Cookies zu. Weitere Informationen finden Sie in unserer Datenschutzerklärung.