Zum Inhalt springen
Das deutsche VCDS Forum
Das deutsche VCDS Forum

HEX+CAN-USB und Webasto Software


Empfohlene Beiträge

Hallo zusammen,

ich habe zwei Anliegen:

 

  1. Ich brauche den Treiber, der nötig ist,um das HEX+CAN-USB mit der Diagnosesoftware von Webasto (ThermoTest) zu verwenden.
  2. Funktioniert das HEX+CAN-USB auch mit der Webasto Aufrüstsoftware? (Zuheizer > Standheizung)

 

Vielen Dank und frohes Fest

Link zu diesem Kommentar

Habe einen Beitrag gefunden, indem diejenigen, die den Treiber möchten, gebeten werden, ihren Vertriebspartner anzuschreiben, da man hier ein paar Sachen beachten muss.

 

Außerdem möchte ich noch wissen, ob und an welchen Pin man problemlos die Standheizungsdiagnose an die fahrzeugseitige Diagnosesteckdose legen kann. Danke!

Bearbeitet von fuchs_100
Link zu diesem Kommentar

Achso, ja 2x2 Adapter benutz ich halt und ansonsten gibts ja von Webasto schon zahlreiche zum Dazwischenstecken am Heizgerät oder zum direkten Anstecken. Aber da hab ich keinen von denen. Bau ich mir, falls bedarf wäre wenn dann selbst!

Link zu diesem Kommentar

Kann man die K-Leitung von der ThermoTop (nicht W-Bus) an die K-Leitung von meinem VW Bora klemmen oder ist das ein anderes Protokoll und versteht sich nicht mit dem VW-Protokoll?

 

Dann könnte man ja direkt an der VW-Diagnosebuchse die Webasto auslesen.

 

Hab das ganze schonmal getestet und die gelbe Leitung von der Standheizung auf die Diagnoseleitung von der Climatronic geklemmt.

 

Dann die COM-Treiber vom Ross-Tech-Interface installiert und Webasto Thermo-Test 2.08 auf Com4 gestellt. Aber Verbindung bekomme ich keine. Standheizung ist dabei natürlich gelaufen...

 

Ist bei dem COM-Treiber automatisch der PIN 7 (K-Leitung) zur Kommunikation ausgewählt?

VCDS HEX+CAN-USB + Hex-Net, Netbook MSI U115 Hybrid, Lenovo ThinkPad SL510, Lenovo X61 mit SATA-II-SSD und einen Bosch DCU220

Bora Highline 2.8 V6 4-motion MJ 00

VW CC 2.0 TDI DSG MJ12

Link zu diesem Kommentar

Soweit meine Kenntniss ist, gibt es keine Treiber für Fremdsoftware mehr. Dies hat sich bei einem der letzten Firmwareupdates erledigt. War meines Wissens notwendig, um die Hex+Can Hardware zum neuen Ibiza kompatibel zu bekommen.

 

Die ganze Geschichte hatte sowieso den Haken, das immer nur 1 Treiber installiert werden konnte, man hat also immer ein Installationsproblem, bzw. mußte virtuelle Rechner benutzen.

 

Für die genannten Zwecke tut es billig Hardware von den Chinesen, wenn ich auch kein Freund davon bin.

 

@koech:

Nein, das geht nicht, die Diagnoseleitungen müssen elektrisch getrennt sein( anderes Protokoll ).

Andy Vetter @ PCI-Diagnosetechnik GmbH&Co.KG

Technische Anfragen im Forum die NICHT von Lizenzinhabern stammen, werden nicht beantwortet.

Aktuelle VCDS Version: Download hier
Aktuelle VCDS Beta Testversion:xxxxx
Aus aktuellem Anlass: "Warum antwortet mir keiner?" ...oder auch "Wie poste ich richtig?"

Link zu diesem Kommentar
@koech:

Nein, das geht nicht, die Diagnoseleitungen müssen elektrisch getrennt sein( anderes Protokoll ).

 

Also wenn ich dann einen Schalter dazwischen stecke, dann sollte es keine Probleme mehr geben. Was ich aber nicht genau verstehe, wenn die Zündung für längere Zeit nicht aktiviert wurde, dann kann ja sowieso kein anderes Steuergerät vom Fahrzeug antworten, auch nicht das Komfortsteuergerät. Oder hat das noch andere Hintergründe? Weil für Standheizungsdiagnose brauch ich ja keine Klemme 15.

 

Den Treiber habe ich installiert und kann mit ein paar Mausklicks umgeschalten werden. Und eine Fehlermeldung erhalte ich im Geräte-Manager auch keine. Der Com-Port aktiviert sich sobald ich das USB-Kabel einstecke.

VCDS HEX+CAN-USB + Hex-Net, Netbook MSI U115 Hybrid, Lenovo ThinkPad SL510, Lenovo X61 mit SATA-II-SSD und einen Bosch DCU220

Bora Highline 2.8 V6 4-motion MJ 00

VW CC 2.0 TDI DSG MJ12

Link zu diesem Kommentar

Hier macht wohl Versuch klug. Es ist vom Fahrzeughersteller nicht vorgesehen worden, aus welchem Grund auch immer, probiert hat es wohl noch keiner. Wundere Dich allerdings nicht, wenn nach Deiner Aktion Probleme am Fahrzeug, bzw. auf der Diagnose auftreten. Ich würde zumindest den Pin für K leitung 2 /L-Leitung benutzen, der dürfte auf Deiner Diagnosesteckdose nicht belegt sein. Ob Du einen Schalter einbauen mußt, oder nicht, mußt Du wie gesagt, probieren.

Andy Vetter @ PCI-Diagnosetechnik GmbH&Co.KG

Technische Anfragen im Forum die NICHT von Lizenzinhabern stammen, werden nicht beantwortet.

Aktuelle VCDS Version: Download hier
Aktuelle VCDS Beta Testversion:xxxxx
Aus aktuellem Anlass: "Warum antwortet mir keiner?" ...oder auch "Wie poste ich richtig?"

Link zu diesem Kommentar
#14 - Geschrieben (bearbeitet)

Also ich hab mir jetzt (aus verzweiflung) den Treiber mit dem virtuellen Com-Port installiert, da ich in letzter Zeit bei verschiedenen Heizungen keine Zugriff mehr hatte mit dem Interface, das ich sonst dafür benutzte. Das ganze kann natürlich auch ein blöder Zufall sein, sodass es an den Heizungen liegt, aber am Montag oder Dienstag werd ichs mal dann mit dem Hex+CAN testen. Die Installation ging problemlos, nur weiß ich im Moment nicht, ob ich überhaupt VCDS damit nutzen könnte, was aber im Moment auch garnicht nötig ist (ich hoffe das bleibt die nächsten Tage so).

 

Man kann die Diganoseleitung der Heizung nicht auf die fahrzeugseitige K-Line legen, Lösung mit Wechselschalter wäre möglich, aber auch aufwändig. Wenn du die Zündung aus lässt und anstatt auf K (7) auf L (15) die Webasto-Leitung legst, dann sollte es gehen.

 

 

Verdammt, 4 Minuten zu spät!

Bearbeitet von fuchs_100
Link zu diesem Kommentar

:hahaha: 2Esel, 1Gedanke !

  • Like 1

Andy Vetter @ PCI-Diagnosetechnik GmbH&Co.KG

Technische Anfragen im Forum die NICHT von Lizenzinhabern stammen, werden nicht beantwortet.

Aktuelle VCDS Version: Download hier
Aktuelle VCDS Beta Testversion:xxxxx
Aus aktuellem Anlass: "Warum antwortet mir keiner?" ...oder auch "Wie poste ich richtig?"

Link zu diesem Kommentar

...nur weiß ich im Moment nicht, ob ich überhaupt VCDS damit nutzen könnte, was aber im Moment auch garnicht nötig ist (ich hoffe das bleibt die nächsten Tage so).

 

Soll ja auch nicht mit VCDS sondern mit Webasto ThermoThest funktionieren.

 

Wenn du die Zündung aus lässt und anstatt auf K (7) auf L (15) die Webasto-Leitung legst, dann sollte es gehen.

 

Aber wie weiß das HEX-CAN-Modul, das es den PIN 15 für die COM-Kommunication nehmen soll?

VCDS HEX+CAN-USB + Hex-Net, Netbook MSI U115 Hybrid, Lenovo ThinkPad SL510, Lenovo X61 mit SATA-II-SSD und einen Bosch DCU220

Bora Highline 2.8 V6 4-motion MJ 00

VW CC 2.0 TDI DSG MJ12

Link zu diesem Kommentar

Mit dem HEX+CAN von hier hab ichs noch nicht getestet, sondern nur mit meinem anderen Interface und da gings. Es muss halt ein sog. KKL fähiges Interface sein. Da werden auf der L-Leitung sozusagen K-Daten übertragen und das Interface checkt das dann und kommuniziert dann darüber. Hier ist beispielsweise der Schaltplan von dem Interface, das ich normalerweise für die Standheizungen und sonstige Diagnose benutze. Ist mit Sicherheit kein China-Schrott, aber wie gesagt, billigere tun es auch!

 

Ich will mein HEX+CAN-USB eigentlich schon vorrangig für VCDS nutzen und für den Rest das andere eben. Ich hab mir jetzt nur den Treiber installiert, damit ich einen defekt am Interface oder ein Problem zwischen der neuesten Version und meinem Interface ausschließen kann.

Link zu diesem Kommentar

ja, sind beide auf einem Rechner. Also zu Beginn hatte ich den Treiber von der mitgeschickten CD drauf, jetzt wo es nicht mehr ging, hab ich den neuesten Treiber von der Herstellerhompage geholt und den von Microsoft angebotenen hab ich auch probiert, das gab aber jeweils keine Änderung. Beim Hex+CAN benutz ich den von der Ross-Tech seite mit VCP (Virtual Com-Port). Da steckst du das Interface faktisch an und dann hast du zum einen das Interace unter USB-Geräte drin und zum Anderen auch noch einen Com-Port. Ich muss jetzt mitm Testen erst bis Anfang nächster Woche warten, da ich für die Heizung keinen Kabelstrang hab. Ich hab nämlich fast die Vermutung, dass durch irgendwelche Treiberupdates Probleme entstehen, sodass die Software mit dem Interface nicht mehr zusammenarbeitet, aber dazu muss ich erst noch demnächst testen. VCDS zeigt mir jetzt natürlich an, dass ich einen alten Treiber hab, was ja logisch ist, denn der ist ja auch alt.

Link zu diesem Kommentar

Hy

Danke für die schnelle antwort

Das AGV läuft bei mir auch unter dem virtuellen Port! Bekomm das HEX-CAN erst nächste woche nur hab ich Angst das sich die zwei nicht miteinander vertragen

Link zu diesem Kommentar

Also für die normale Diagnose vertragen sich die zwei ohne Probleme. Lediglich mit den Standheizungen könnte es eben sein, dass es ein Problem gibt bzw. gab und das möchte ich eben jetzt herausfinden. Leider weiß ich nicht mehr, wann ich die letzte Standheizung diagnostiziert habe und ob ich damals schon das Hex+Can hatte und auch installiert hatte, aber ich glaub fast schon. Und damals gings. Von daher denk ich jetzt nicht, dass es Probleme gibt. Ansonsten brauch ich auch das AGV 4000 garnicht mehr, denn EOBD ist mit VCDS ja auch möglich, auch bei anderen Fahrzeugmarken und das ist super. Nur für Webasto und Eberspächer Diagnose brauch ich halt noch den virtuellen Com-Port.

Link zu diesem Kommentar

Und ich probier das mal mit dem Pin15. Nur kommt man beim Bora nicht grad schön an die Pins von der OBD-Buchse. Ansonsten muss ich halt ne Buchse mit Stromversorgung basteln. Aber dazu muß ich erst mal eine finden. Ich denk irgendwo liegt noch eine rum. Denn nur so mit Krokoklemmen will ich dann auch nicht rumspielen. Nicht, daß sich das Hex+Can in Rauch auflöst. :blush:

VCDS HEX+CAN-USB + Hex-Net, Netbook MSI U115 Hybrid, Lenovo ThinkPad SL510, Lenovo X61 mit SATA-II-SSD und einen Bosch DCU220

Bora Highline 2.8 V6 4-motion MJ 00

VW CC 2.0 TDI DSG MJ12

Link zu diesem Kommentar

Also das Hex+CAN hat nicht gearbeitet mit der Webasto Software. Jetzt hatte ich sogar VCDS vom PC entfernt, aber es ging immer noch nix (mitm AGV wieder gearbeitet!). Es arbeitete, wie man an der LED sehen konnte, aber es kam keine Antwort vom Steuergerät. Dann fiel mir der entscheidende Punkt ein! Aufgrund eines Treiberupdates (die erfolgen ja anscheinend auch automatisch über Microsoft und Microsoft hat einen Treiber von FTDI haben sich die Einstellungen wohl wieder auf Urzustand zurückgesetzt. Latency Time wieder auf die kleinste Stufe (1 msec) gesetzt und es läuft wieder wie geschmiert, auch mit Thermo Test 2.09!

 

Pin 15 wird bei mir demnächst eben auch an meinem eigenen mit der Webasto Diagnoseleitung belegt, nur bei mir gehts sehr einfach und schnell, da die Steckdose wunderbar zugänglich ist. Dem Hex+CAN dürfte das nix machen, es ist lediglich möglich, dass die Fahrzeugdiagnose gestört wird durch die Standheizung.

Link zu diesem Kommentar

...Latency Time wieder auf die kleinste Stufe (1 msec) gesetzt und es läuft wieder wie geschmiert, auch mit Thermo Test 2.09!...

:schild14:

Wo stellt man die ein? Meinst Du die Com-Port-Einstellungen von Windows?

VCDS HEX+CAN-USB + Hex-Net, Netbook MSI U115 Hybrid, Lenovo ThinkPad SL510, Lenovo X61 mit SATA-II-SSD und einen Bosch DCU220

Bora Highline 2.8 V6 4-motion MJ 00

VW CC 2.0 TDI DSG MJ12

Link zu diesem Kommentar
  • Das Thema wurde aufgrund fehlender Aktivität nach 365 Tagen automatisch geschlossen.
Gast
Dieses Thema wurde nun für weitere Antworten gesperrt.
×
×
  • Neu erstellen...

Wichtige Information

Wir benutzen Cookies, um Ihnen den bestmöglichen Service bieten zu können. Durch die weitere Nutzung dieser Webseite stimmen Sie der Verwendung von Cookies zu. Weitere Informationen finden Sie in unserer Datenschutzerklärung.